您现在的位置: 大智慧股民之家 >> 股票知识 >> 股票公式 >> 公式编写 >> 正文
大智慧公式教程:逻辑函数
2008-7-26 来源:本站原创 字号:【

大智慧逻辑函数

1、IF 条件函数 根据条件求不同的值。 用法:IF(X,A,B)若X不为0则返回A,否则返回B。 例如:IF(CLOSE>OPEN,HIGH,LOW),表示该周期收阳则返回最高值,否

则返回最低值。
2、CROSS 交叉函数 CROSS(A,B) A:变量或常量,判断交叉的第一条线。 B:变量或常量,判断交叉的第二条线。 例如:CROSS(MA(CLOSE,5),MA(CLOSE,10)),5

日均线与10日均线金叉;CROSS(CLOSE,12),价格由下向上突破12元。
上面这两个函数我们在前面已经讲过,在此就不做介绍了。讲一讲下面几个逻辑函数。
这几个逻辑函数比较好理解,用法简单,只是用的很少。
3、ISDOWN 当日下跌 该周期是否收阴。 用法:ISDOWN当收盘<开盘时,返回值为1,否则为0。
4、ISEQUAL 当日平盘 该周期是否平盘。 用法:ISEQUAL当收盘=开盘时,返回值为1,否则为0。
5、ISUP   该周期是否收阳。 用法:ISUP当收盘>开盘时,返回值为1,否则为0。请看指标:
Var1:=EMA(CLOSE,3);
Var2:=EMA(CLOSE,21);
Var3:=BARSLAST(CROSS(Var2,Var1))>15;
Var4:=VOL>MA(VOL,5)*2 AND VOL<MA(VOL,5)*5;
Var5:=CROSS(Var1,Var2) AND ISUP AND Var4 AND Var3;{交叉(var1,var2)并且 当日上涨 并且VAR4 并且VAR3}
:if(Var5,80,0),stick,linethick4,colorf00ff0;
drawtext(Var5,70,'!'),colorf00ff0;


6、NOT 求逻辑非 NOT(X) 求逻辑非,返回非X,即当X=0时返回1,否则返回0。 例如:NOT(ISUP),是否平盘或收阴。请看指标:
XX2:=(MA(CLOSE,80)-MA(CLOSE,13)/3);
神奇线: MA((CLOSE-XX2)/XX2,1);
买点1: IF(CROSS(神奇线,0) AND LOW/REF(HIGH,1)<1.012,0.5,0), STICK,COLORWHITE;
稳赚: IF(COUNT(神奇线>REF(神奇线,1),3)=3 AND COUNT(神奇线<0,10)=10 AND REF(神奇线,3)=LLV(神奇线,10),0.5,0);
买点2: IF(REF(神奇线,2)=LLV(神奇线,20) AND REF(神奇线,2)<0.071 AND REF(神奇线,2)<REF(神奇线,1) AND NOT(REF(LOW,1)>REF(HIGH,2) AND LOW>REF

(HIGH,1)) AND CLOSE>REF(CLOSE,1),0.5,0),COLORRED;{这段语句NOT(REF(LOW,1)>REF(HIGH,2)的意思,是否昨天最低价大于前天最高价,这几个条件都满足显

示脉冲信号,否则不显示}
DRAWTEXT( 买点1>0,0.2 ,'★神奇线'),COLORWHITE;
DRAWTEXT( 买点2>0,0.4 , '★神奇线'),COLORRED;

 

  郑重声明:大智慧股民之家刊登〖大智慧公式教程:逻辑函数〗一文目的在于传播更多信息,与本网站立场无关。本版文章的原创性以及文中陈述文字和内容并未经过本站证实,大智慧股民之家不保证其内容的准确性、可靠性和有效性,仅供投资者参考,并不构成投资建议。投资者据此操作,风险自担,并请自行核实相关内容。 如对本文内容有疑议,请及时与我们联系。
分享到:

相关阅读:

股票在线视频: